IFrame (deprecated)

Category: Widgets
Subcategory: Buttons

Overview

The widget is considered deprecated. If you need to use an IFrame, consider the "IFrame Component" widget The Iframe can be used to embed websites in the client. Its URL is read from a String attribute of the dataview it is embedded in.

Documentation

 Name

IFrame

 AuthorMendix, Michel Weststrate
 TypeWidget Latest Version
1.0
 Package filename
IFrame.mpk

Description

 

The Iframe can be used to embed websites in the client. Its URL is read from a String attribute of the dataview it is embedded in.

Typical usage scenario

 

  • Embed an external website in a form
  • Show search results for a specifiek object, for example by using prefix 'http://www.google.com/search?q='

Features and limitations

 

  • (Partial) dynamic URLs, depending on your domain model
  • Scroll behavior is configurable but not guaranteed

Installation

 

See the general instructions under How to Install.

Dependencies

 

  • Mendix 2.5 Environment

Configuration

 

  • The widget should be embedded in a dataview with a String or Integer attribute.

 

Properties

Height

Height of the viewer in pixels. Use '0' to determine the width automatically. This will use any remaining space.

Scroll [auto, always, never]

Defines whether to scroll when the contents exceed the IFrame size. Always will show scrollbars even if not strictly needed. Default: auto

Setting this property does not guarantee the expected behavior, the styling of the website displayed has much influence on the scrolling behavior of the iframe.

URL Attribute

The attribute that returns the URL of the IFrame.

URL prefix

Optional URL prefix. The attribute value is prefixed with this value.

Known bugs

 

  • None

 

Frequently Asked Questions

 

Ask your question at the Mendix Community Forum

 

  • None

Releases

Version: 3.1.2
Framework Version: 6.0.1
Release Notes: - Bugfix release for MX9
Version: 3.1.1
Framework Version: 6.0.1
Release Notes: - Fix #2 Problems with closing page (IFrame refreshes when closing, preventing closing the page)
Version: 3.1
Framework Version: 6.0.1
Release Notes: - Refactoring code
Version: 3.0
Framework Version: 6.0.1
Release Notes: Compatible with 5.10 and up
Version: 2.0
Framework Version: 6.0.1
Release Notes: Version compatible with MX5, for MX4 and earlier please download a different version (check releasenotes and mendix version).